Sun, 21 Jul 2013 12:54:27 -0700 Fixed bug 1813 - MouseMotion relative values do not respect renderer LogicalSize
Sam Lantinga <slouken@libsdl.org> [Sun, 21 Jul 2013 12:54:27 -0700] rev 7496
Fixed bug 1813 - MouseMotion relative values do not respect renderer LogicalSize driedfruit A trivial issue, the xrel and yrel values of MouseMotion event struct are not adjusted to renderer logical size.
Sun, 21 Jul 2013 12:47:47 -0700 Fixed bug 1973 - test/Makefile.in fails on Mac OS X with X11 enabled...
Sam Lantinga <slouken@libsdl.org> [Sun, 21 Jul 2013 12:47:47 -0700] rev 7495
Fixed bug 1973 - test/Makefile.in fails on Mac OS X with X11 enabled... Ryan C. Gordon If you have the X11 SDK installed on Mac OS X, you'll build with X11 support, but the Makefile doesn't build anything but the Cocoa testnative code for Mac OS X, which is fine, but then testnative fails to link because testnative.h enables the X11 support based on the SDL config header. Building the testnativex11.c code on Mac OS X doesn't work because you need to explicitly link with "-L/usr/X11/lib -lX11" if this code is enabled, but you can't link with that by default because the X11 SDK might be missing. So this needs a little configure magic to do the right thing (or forcibly disabling X11 support on Mac OS X in testnative.h).
Sun, 21 Jul 2013 12:37:43 -0700 Added X include path so SDL_syswm.h works correctly on systems with X11 in a non-standard directory.
Sam Lantinga <slouken@libsdl.org> [Sun, 21 Jul 2013 12:37:43 -0700] rev 7494
Added X include path so SDL_syswm.h works correctly on systems with X11 in a non-standard directory.
Sun, 21 Jul 2013 12:21:22 -0700 Fixed cursor leak when quitting the mouse subsystem
Sam Lantinga <slouken@libsdl.org> [Sun, 21 Jul 2013 12:21:22 -0700] rev 7493
Fixed cursor leak when quitting the mouse subsystem
Sun, 21 Jul 2013 11:52:16 -0700 Fixed bug 1976 - SDL2.m4 shares same variables as SDL.m4 so they cache values
Sam Lantinga <slouken@libsdl.org> [Sun, 21 Jul 2013 11:52:16 -0700] rev 7492
Fixed bug 1976 - SDL2.m4 shares same variables as SDL.m4 so they cache values Edgar Simo So basically the issue is that: AC_PATH_PROG(SDL_CONFIG, sdl2-config, no, [$PATH]) in sdl2.m4 shares the same variable (SDL_CONFIG) as sdl.m4: AC_PATH_PROG(SDL_CONFIG, sdl-config, no, [$PATH]) What happens is if you run the AM_PATH_SDL2 and then AM_PATH_SDL to say fall back on SDL if SDL2 isn't found, the AM_PATH_PROG command gets cached (ac_cv_path_SDL_CONFIG) so that unless you unset this cache variable, the result for AM_PATH_SDL will be EXACTLY the same as for AM_PATH_SDL2. To fix I would recommend renaming SDL_CONFIG to SDL2_CONFIG in sdl2.m4, replacing all instances so it won't cache to the same variable.
Sun, 21 Jul 2013 11:09:53 -0700 Fixed bug 1979 - X11_SetGammaRamp doesn't check the return value of XStoreColors SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Sun, 21 Jul 2013 11:09:53 -0700] rev 7491
Fixed bug 1979 - X11_SetGammaRamp doesn't check the return value of XStoreColors Sven Hesse Here on my laptop with an ATI Mobility Radeon 9600 PRO Turbo (RV350), the free radeon drivers and X.org 1.12.4, SDL_SetGamma() fails because it tries to use SDL_SetGammaRamp() if available. SDL_SetGammaRamp() uses XStoreColors(), and that call always fails with BadRequest (for whatever reason, I don't know). The SDL_Visual class check goes through, though. Now, XStoreColors failing is maybe another bug in SDL, or in Xorg, or in the radeon drivers or anywhere else, but I think SDL should still check that the XStoreColors() doesn't error as well.
Sun, 21 Jul 2013 00:57:31 -0400 Add support for the _NET_WM_BYPASS_COMPOSITOR hint
Jasper St. Pierre <jstpierre@mecheye.net> [Sun, 21 Jul 2013 00:57:31 -0400] rev 7490
Add support for the _NET_WM_BYPASS_COMPOSITOR hint This hints to window managers to unredirect the window to improve performance.
Sun, 21 Jul 2013 00:07:43 -0400 Cursor mask was uninitialized data, causing problems.
Ryan C. Gordon <icculus@icculus.org> [Sun, 21 Jul 2013 00:07:43 -0400] rev 7489
Cursor mask was uninitialized data, causing problems. Fixes Bugzilla #1461.
Sat, 20 Jul 2013 21:22:37 -0400 Include SDL_assert.h to fix broken build.
Ryan C. Gordon <icculus@icculus.org> [Sat, 20 Jul 2013 21:22:37 -0400] rev 7488
Include SDL_assert.h to fix broken build.
Sat, 20 Jul 2013 21:19:20 -0400 Don't allocate memory if we're just going to fail when checking parameters.
Ryan C. Gordon <icculus@icculus.org> [Sat, 20 Jul 2013 21:19:20 -0400] rev 7487
Don't allocate memory if we're just going to fail when checking parameters.
(0) -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 tip