Sun, 01 Oct 2006 16:10:41 +0000 Double Whoops. :P
Ryan C. Gordon <icculus@icculus.org> [Sun, 01 Oct 2006 16:10:41 +0000] rev 2048
Double Whoops. :P
Sun, 01 Oct 2006 16:07:32 +0000 Whoops. :)
Sam Lantinga <slouken@libsdl.org> [Sun, 01 Oct 2006 16:07:32 +0000] rev 2047
Whoops. :)
Sun, 01 Oct 2006 02:28:41 +0000 Replaced strncmp for SDL_VIDEODRIVER test with strcasecmp
Sam Lantinga <slouken@libsdl.org> [Sun, 01 Oct 2006 02:28:41 +0000] rev 2046
Replaced strncmp for SDL_VIDEODRIVER test with strcasecmp
Sun, 01 Oct 2006 02:06:37 +0000 Replaced strncmp for SDL_AUDIODRIVER test with strcasecmp.
Ryan C. Gordon <icculus@icculus.org> [Sun, 01 Oct 2006 02:06:37 +0000] rev 2045
Replaced strncmp for SDL_AUDIODRIVER test with strcasecmp. Fixes Bugzilla #334.
Sun, 01 Oct 2006 01:12:08 +0000 Minor cleanup in the mint driver that was sitting on my laptop (sorry!).
Ryan C. Gordon <icculus@icculus.org> [Sun, 01 Oct 2006 01:12:08 +0000] rev 2044
Minor cleanup in the mint driver that was sitting on my laptop (sorry!).
Sun, 24 Sep 2006 15:56:55 +0000 Formatting update
Sam Lantinga <slouken@libsdl.org> [Sun, 24 Sep 2006 15:56:55 +0000] rev 2043
Formatting update
Sun, 24 Sep 2006 15:56:36 +0000 Fixed bug #292
Sam Lantinga <slouken@libsdl.org> [Sun, 24 Sep 2006 15:56:36 +0000] rev 2042
Fixed bug #292 I might be on crack here. It looks like SDL_ConvertMono() in src/audio/SDL_audiocvt.c adds the left and right channels of a stereo stream together, and clamps the new mono channel if it would overflow. Shouldn't it be dividing by 2 to average the two sample points instead of clamping? Otherwise the mono sample point's volume doubles in the conversion. This would also make the conversion faster, as it replaces two branches per sample frame with a bitwise shift. --ryan.
Sun, 24 Sep 2006 00:55:19 +0000 Fixed bug #316
Sam Lantinga <slouken@libsdl.org> [Sun, 24 Sep 2006 00:55:19 +0000] rev 2041
Fixed bug #316 Looks like this is a long standing typo... is this code even used anymore?
Sun, 24 Sep 2006 00:44:45 +0000 Fixed bug #321
Sam Lantinga <slouken@libsdl.org> [Sun, 24 Sep 2006 00:44:45 +0000] rev 2040
Fixed bug #321 Hi, if "configure" is given an explicit --libdir, the sdl-config still contains the default "${exec_prefix}/lib" for runtime linker path. That should be changed to $libdir, as this is where the library goes to... Regards, Juergen
Sun, 24 Sep 2006 00:36:49 +0000 Fixed bug #270
Sam Lantinga <slouken@libsdl.org> [Sun, 24 Sep 2006 00:36:49 +0000] rev 2039
Fixed bug #270 SDL_SetCursor returns void, not void*
(0) -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 tip