Fixed bug #220
authorSam Lantinga <slouken@libsdl.org>
Tue, 09 May 2006 15:09:47 +0000
changeset 1795 398ac0f88e4d
parent 1794 5605a9820134
child 1796 00ea6cf49a4e
Fixed bug #220 The AltiVec blitters don't compile, since they require __VEC__ to be enabled in order for the compiler to understand "vector" and friends (i.e. do AltiVec) But you don't want to turn AltiVec on globally, since then the code would only run on a G4 (there are already runtime tests, before using the AltiVec variants) The solution here is to enable AltiVec locally, for the actual AltiVec code.
src/video/SDL_blit_A.c
src/video/SDL_blit_N.c
--- a/src/video/SDL_blit_A.c	Tue May 09 08:52:54 2006 +0000
+++ b/src/video/SDL_blit_A.c	Tue May 09 15:09:47 2006 +0000
@@ -637,6 +637,9 @@
 #endif /* GCC_ASMBLIT, MSVC_ASMBLIT */
 
 #if SDL_ALTIVEC_BLITTERS
+#if __MWERKS__
+#pragma altivec_model on
+#endif
 #if HAVE_ALTIVEC_H
 #include <altivec.h>
 #endif
@@ -1406,6 +1409,9 @@
         dstp += dstskip;
     }
 }
+#if __MWERKS__
+#pragma altivec_model off
+#endif
 #endif /* SDL_ALTIVEC_BLITTERS */
 
 /* fast RGB888->(A)RGB888 blending with surface alpha=128 special case */
--- a/src/video/SDL_blit_N.c	Tue May 09 08:52:54 2006 +0000
+++ b/src/video/SDL_blit_N.c	Tue May 09 15:09:47 2006 +0000
@@ -29,6 +29,9 @@
 /* Functions to blit from N-bit surfaces to other surfaces */
 
 #if SDL_ALTIVEC_BLITTERS
+#if __MWERKS__
+#pragma altivec_model on
+#endif
 #ifdef HAVE_ALTIVEC_H
 #include <altivec.h>
 #endif
@@ -830,6 +833,9 @@
     }
     return features;
 }
+#if __MWERKS__
+#pragma altivec_model off
+#endif
 #else
 /* Feature 1 is has-MMX */
 #define GetBlitFeatures() ((Uint32)(SDL_HasMMX() ? 1 : 0))