Date: Wed, 17 Aug 2005 11:23:40 -0400
authorRyan C. Gordon <icculus@icculus.org>
Thu, 18 Aug 2005 06:06:02 +0000
changeset 1118 65f4b2dd46b7
parent 1117 95b261f445b1
child 1119 430d8d701f69
Date: Wed, 17 Aug 2005 11:23:40 -0400 From: Matt L <prometheus.uw@gmail.com> To: "Ryan C. Gordon" <icculus@clutteredmind.org> Subject: SDL Patch Hio, I saw your last call on the mailing list. Here's a patch which I submitted about two weeks ago which hasn't made it in. In the current sdl.m4, there's a bug where if your configure.ac, you have AC_LANG(C++) specified, it won't properly compile and link the SDL test program when you run the configure script. This is because only the default CFLAGS is overriden in sdl.m4, and in the patch below, I've fixed it so it overrides CXXFLAGS as well, allowing it to work with g++.
sdl.m4
--- a/sdl.m4	Wed Aug 17 00:19:45 2005 +0000
+++ b/sdl.m4	Thu Aug 18 06:06:02 2005 +0000
@@ -52,8 +52,10 @@
            sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
     if test "x$enable_sdltest" = "xyes" ; then
       ac_save_CFLAGS="$CFLAGS"
+      ac_save_CXXFLAGS="$CXXFLAGS"
       ac_save_LIBS="$LIBS"
       CFLAGS="$CFLAGS $SDL_CFLAGS"
+      CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
       LIBS="$LIBS $SDL_LIBS"
 dnl
 dnl Now check if the installed SDL is sufficiently new. (Also sanity
@@ -138,6 +140,7 @@
        else
           echo "*** Could not run SDL test program, checking why..."
           CFLAGS="$CFLAGS $SDL_CFLAGS"
+          CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
           LIBS="$LIBS $SDL_LIBS"
           AC_TRY_LINK([
 #include <stdio.h>
@@ -162,10 +165,12 @@
           echo "*** or that you have moved SDL since it was installed. In the latter case, you"
           echo "*** may want to edit the sdl-config script: $SDL_CONFIG" ])
           CFLAGS="$ac_save_CFLAGS"
+          CXXFLAGS="$ac_save_CXXFLAGS"
           LIBS="$ac_save_LIBS"
        fi
      fi
      SDL_CFLAGS=""
+     SDL_CXXFLAGS=""
      SDL_LIBS=""
      ifelse([$3], , :, [$3])
   fi