Fixed bug #895 SDL-1.2
authorSam Lantinga <slouken@libsdl.org>
Fri, 11 Dec 2009 15:14:13 +0000
branchSDL-1.2
changeset 4390 725e506f6243
parent 4389 c6c3a6e7db46
child 4391 07b330419439
Fixed bug #895 Markus Rothe 2009-12-07 09:32:46 PST Check if libspe2 is available Building on PowerPC64 results in: [...] In file included from ./src/video/ps3/SDL_ps3events_c.h:33, from ./src/video/ps3/SDL_ps3video.c:32: ./src/video/ps3/SDL_ps3video.h:34:21: error: libspe2.h: No such file or directory In file included from ./src/video/ps3/SDL_ps3events_c.h:33, from ./src/video/ps3/SDL_ps3video.c:32: ./src/video/ps3/SDL_ps3video.h:75: error: expected specifier-qualifier-list before 'spe_context_ptr_t' ./src/video/ps3/SDL_ps3video.c:78: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'fb_writer_spu' ./src/video/ps3/SDL_ps3video.c: In function 'PS3_VideoInit': ./src/video/ps3/SDL_ps3video.c:167: error: 'spu_data_t' has no member named 'program' ./src/video/ps3/SDL_ps3video.c:167: error: 'fb_writer_spu' undeclared (first use in this function) [...] The problem is that the ps3 video driver is being build regardless if libspe2 is installed or not. The attached patch fixes this problem. [ Note: The other headers that are being checked for are coming from the linux headers package on powerpc64. As a result these are also available if you're on a generic powerpc64 machine and not a PS3 only. ]
configure.in
--- a/configure.in	Fri Dec 11 15:11:49 2009 +0000
+++ b/configure.in	Fri Dec 11 15:14:13 2009 +0000
@@ -1317,6 +1317,7 @@
     AC_TRY_COMPILE([
       #include <linux/fb.h>
       #include <asm/ps3fb.h>
+      #include <libspe2.h>
     ],[
     ],[
       video_ps3=yes