ate: Mon, 4 Aug 2003 19:10:14 +0300
authorSam Lantinga <slouken@libsdl.org>
Wed, 06 Aug 2003 20:20:30 +0000
changeset 666 fbec2501cf9f
parent 665 d27aab66c5d6
child 667 adbed8d7a991
ate: Mon, 4 Aug 2003 19:10:14 +0300 From: "Mike Gorchak" Subject: SDL/QNX forgotten fixes Just found, that one chunk for configure.in has not been applied and one for\ gotten by me :) Please add it to CVS. P.S. Now QNX6.2.1 have the dlopen in libc and in the libltdl. So libc's vari\ ant more prefered, and ltdl rest for compatibility. In this small patch I wa\ s added proper checks.
configure.in
--- a/configure.in	Wed Aug 06 20:12:00 2003 +0000
+++ b/configure.in	Wed Aug 06 20:20:30 2003 +0000
@@ -1054,7 +1054,7 @@
             CFLAGS="$CFLAGS -DHAVE_OPENGL"
             SYSTEM_LIBS="$SYSTEM_LIBS -lGL"
             if test x$use_dlopen != xyes; then
-                AC_CHECK_LIB(ltdl, dlopen, SYSTEM_LIBS="$SYSTEM_LIBS -lltdl")
+                AC_CHECK_LIB(c, dlopen, SYSTEM_LIBS="$SYSTEM_LIBS", AC_CHECK_LIB(ltdl, dlopen, SYSTEM_LIBS="$SYSTEM_LIBS -lltdl"))
             fi
         fi
     fi
@@ -2215,7 +2215,7 @@
         COPY_ARCH_SRC(src/main, linux, SDL_main.c)
         # Set up files for the audio library
         if test x$enable_audio = xyes; then
-            CFLAGS="$CFLAGS -DALSA_SUPPORT"
+            CFLAGS="$CFLAGS -DQNXNTOAUDIO_SUPPORT"
             SYSTEM_LIBS="$SYSTEM_LIBS -lasound"
             AUDIO_SUBDIRS="$AUDIO_SUBDIRS nto"
             AUDIO_DRIVERS="$AUDIO_DRIVERS nto/libaudio_nto.la"