Braid installer: allow forcing of 32-bit install from command line. braid-installer-2
authorRyan C. Gordon <icculus@icculus.org>
Sat, 18 Dec 2010 03:33:08 -0500
changeset 806 69c6bb824fe1
parent 805 4730a8dacfdd
child 807 cf1b48954971
Braid installer: allow forcing of 32-bit install from command line.
examples/braid/scripts/config.lua
--- a/examples/braid/scripts/config.lua	Sat Dec 18 03:24:54 2010 -0500
+++ b/examples/braid/scripts/config.lua	Sat Dec 18 03:33:08 2010 -0500
@@ -4,8 +4,11 @@
 
 local _ = MojoSetup.translate
 
--- grumble.
+-- If we decide you have a 32-bit machine, we don't give you the install
+--  choice. If we think you're on 64-bit, we'll ask which you want, defaulting
+--  to 64.
 local is32bit =
+        MojoSetup.cmdline("32bit") or
         MojoSetup.info.machine == "x86" or
         MojoSetup.info.machine == "i386" or
         MojoSetup.info.machine == "i586" or