build-scripts/emscripten-buildbot.sh
changeset 9288 573ebcb470a3
parent 9285 559ac7dd4ee4
--- a/build-scripts/emscripten-buildbot.sh	Wed Dec 24 13:21:28 2014 -0500
+++ b/build-scripts/emscripten-buildbot.sh	Wed Dec 24 13:23:48 2014 -0500
@@ -47,12 +47,11 @@
 set -x
 cd "$SDLBASE"
 rm -rf buildbot
-rm -rf emscripten-sdl2-installed
 mkdir buildbot
 pushd buildbot
 
 echo "Configuring..."
-emconfigure ../configure --host=asmjs-unknown-emscripten --disable-assembly --disable-threads --enable-cpuinfo=false CFLAGS="-O2 -Wno-warn-absolute-paths -Wdeclaration-after-statement -Werror=declaration-after-statement" --prefix="$SDLBASE/emscripten-sdl2-installed"
+emconfigure ../configure --host=asmjs-unknown-emscripten --disable-assembly --disable-threads --enable-cpuinfo=false CFLAGS="-O2 -Wno-warn-absolute-paths -Wdeclaration-after-statement -Werror=declaration-after-statement" --prefix="$PWD/emscripten-sdl2-installed"
 
 echo "Building..."
 emmake $MAKE
@@ -60,9 +59,9 @@
 echo "Moving things around..."
 emmake $MAKE install
 # Fix up a few things to a real install path
-perl -w -pi -e "s#$SDLBASE/emscripten-sdl2-installed#/usr/local#g;" ./emscripten-sdl2-installed/lib/libSDL2.la ./emscripten-sdl2-installed/lib/pkgconfig/sdl2.pc ./emscripten-sdl2-installed/bin/sdl2-config
+perl -w -pi -e "s#$PWD/emscripten-sdl2-installed#/usr/local#g;" ./emscripten-sdl2-installed/lib/libSDL2.la ./emscripten-sdl2-installed/lib/pkgconfig/sdl2.pc ./emscripten-sdl2-installed/bin/sdl2-config
 mkdir -p ./usr
-mv "$SDLBASE/emscripten-sdl2-installed" ./usr/local
+mv ./emscripten-sdl2-installed ./usr/local
 popd
 tar -cJvvf $TARBALL -C buildbot usr
 rm -rf buildbot