Tue, 24 Jun 2014 13:31:25 -0700 Fixed bug 2553 - Add support to all XInput devices
Sam Lantinga <slouken@libsdl.org> [Tue, 24 Jun 2014 13:31:25 -0700] rev 8920
Fixed bug 2553 - Add support to all XInput devices This adds support for all XInput devices, exposed through the SDL joystick API. The button and axis reporting for XInput devices has been changed to match DirectInput and other platforms. The game controller xinput mapping has been updated so this change is seamless. There is a new hint, SDL_HINT_XINPUT_USE_OLD_JOYSTICK_MAPPING, for any applications that have hardcoded the old xinput button and axis set. This hint will be removed in SDL 2.1.
Tue, 24 Jun 2014 01:38:21 -0700 Fixed bug 2467 - bad memcpy in SDL_OpenAudio/open_audio_device/prepare_audiospec chain
Sam Lantinga <slouken@libsdl.org> [Tue, 24 Jun 2014 01:38:21 -0700] rev 8919
Fixed bug 2467 - bad memcpy in SDL_OpenAudio/open_audio_device/prepare_audiospec chain Rainer Deyke If 'SDL_OpenAudio' is called with 'obtained == NULL', 'prepare_audiospec' performs a bad 'memcpy' with the destination and source pointing to the same block of memory. The problem appears to be on in 'SDL_OpenAudio', which calls open_audio_device with 'obtained = desired' when 'obtained == NULL'. 'open_audio_device' cannot deal with 'desired' and 'obtained' pointing to the same block of memory but can deal with 'obtained == NULL'
Tue, 24 Jun 2014 01:32:20 -0700 Fixed compiling SDL 1.2 with Xcode 5.1.1 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Tue, 24 Jun 2014 01:32:20 -0700] rev 8918
Fixed compiling SDL 1.2 with Xcode 5.1.1
Mon, 23 Jun 2014 11:06:50 -0700 Don't redefine standard macros, use SDL specific macros instead to avoid compiler warnings
Sam Lantinga <slouken@libsdl.org> [Mon, 23 Jun 2014 11:06:50 -0700] rev 8917
Don't redefine standard macros, use SDL specific macros instead to avoid compiler warnings
Mon, 23 Jun 2014 10:09:15 -0700 Fixed grab interaction with Windows Classic theme
Sam Lantinga <slouken@libsdl.org> [Mon, 23 Jun 2014 10:09:15 -0700] rev 8916
Fixed grab interaction with Windows Classic theme Testing: * For each theme in Windows 7, Windows 7 Basic, and Windows 7 Classic: - Ran testsprite2 - Pressed Ctrl-G to grab the mouse - Alt-tabbed away, verified mouse is no longer grabbed - Alt-tabbed back, verified that mouse was grabbed - Alt-tabbed away - Clicked in the window, verified mouse was grabbed - Alt-tabbed away - Grabbed the title bar and dragged the window around successfully, verified that mouse was grabbed when move modal loop completed - Alt-tabbed away - Clicked the minimize button on the title bar, the window was successfully minimized - Clicked on the icon in the task bar, the window was restored and the mouse grabbed again - Alt-tabbed away - Clicked the close button on the title bar, the window was successfully closed
Mon, 23 Jun 2014 10:09:13 -0700 Added names for some theme related windows messages
Sam Lantinga <slouken@libsdl.org> [Mon, 23 Jun 2014 10:09:13 -0700] rev 8915
Added names for some theme related windows messages
Mon, 23 Jun 2014 11:29:53 -0400 Backport gcc-fat.sh and g++-fat.sh to the 1.2 branch to help buildbot. SDL-1.2
Ryan C. Gordon <icculus@icculus.org> [Mon, 23 Jun 2014 11:29:53 -0400] rev 8914
Backport gcc-fat.sh and g++-fat.sh to the 1.2 branch to help buildbot.
Mon, 23 Jun 2014 09:25:27 -0300 Fixes OpenGL ES 2 renderer (Thanks Sylvain Becker)
Gabriel Jacobo <gabomdq@gmail.com> [Mon, 23 Jun 2014 09:25:27 -0300] rev 8913
Fixes OpenGL ES 2 renderer (Thanks Sylvain Becker)
Mon, 23 Jun 2014 09:18:31 -0300 Fix compiler warning
Gabriel Jacobo <gabomdq@gmail.com> [Mon, 23 Jun 2014 09:18:31 -0300] rev 8912
Fix compiler warning
Sun, 22 Jun 2014 11:08:33 -0700 Fixed bug 2560 - Crash on any input SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Sun, 22 Jun 2014 11:08:33 -0700] rev 8911
Fixed bug 2560 - Crash on any input Alex Marshall On all of my OSX machines running 10.9 (I posted OS as Mac OS X (All) due to there not being a 10.9 selection), I get a crash on any input using SDL 1.2. I've had this issue in both HG 1.2 and final release 1.2 on the website. Today I got around to trying to fix it; commenting out the two uses of 'field_edit' in src/video/quartz/SQL_QuartzEvents.m fixes the crash and doesn't cause any side effects as far as I can tell.
(0) -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 tip