Tue, 08 Mar 2011 16:58:25 -0800 Added missing test program
Sam Lantinga <slouken@libsdl.org> [Tue, 08 Mar 2011 16:58:25 -0800] rev 5453
Added missing test program
Mon, 07 Mar 2011 23:27:51 -0800 Fixed 64-bit compiling
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 23:27:51 -0800] rev 5452
Fixed 64-bit compiling
Mon, 07 Mar 2011 22:06:12 -0800 The msimg library isn't needed anymore.
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 22:06:12 -0800] rev 5451
The msimg library isn't needed anymore.
Mon, 07 Mar 2011 22:04:10 -0800 The MMX and 3DNow! instructions can't be compiled by 64-bit Visual Studio.
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 22:04:10 -0800] rev 5450
The MMX and 3DNow! instructions can't be compiled by 64-bit Visual Studio.
Mon, 07 Mar 2011 22:03:29 -0800 The msimg library isn't needed anymore.
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 22:03:29 -0800] rev 5449
The msimg library isn't needed anymore.
Mon, 07 Mar 2011 22:03:11 -0800 Fixed the libraries linked with Visual Studio 2010, the msimg library isn't needed anymore.
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 22:03:11 -0800] rev 5448
Fixed the libraries linked with Visual Studio 2010, the msimg library isn't needed anymore.
Mon, 07 Mar 2011 14:07:08 -0800 Fixed compiler warning on Visual C++
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 14:07:08 -0800] rev 5447
Fixed compiler warning on Visual C++
Mon, 07 Mar 2011 14:06:46 -0800 Fixed bug 1161 (Setting GL_ACCELERATED_VISUAL to 1 forces software rendering in Windows XP)
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 14:06:46 -0800] rev 5446
Fixed bug 1161 (Setting GL_ACCELERATED_VISUAL to 1 forces software rendering in Windows XP) Jesse Anders 2011-03-05 23:30:09 PST It seems that in Windows XP, setting SDL_GL_ACCELERATED_VISUAL to 1 actually disables hardware acceleration and puts OpenGL in software mode. In the source code, the corresponding WGL attribute is first set here: *iAttr++ = WGL_ACCELERATION_ARB; *iAttr++ = WGL_FULL_ACCELERATION_ARB; Later, this code: if (_this->gl_config.accelerated >= 0) { *iAttr++ = WGL_ACCELERATION_ARB; *iAttr++ = (_this->gl_config.accelerated ? WGL_GENERIC_ACCELERATION_ARB : WGL_NO_ACCELERATION_ARB); } Sets it again if SDL_GL_ACCELERATED_VISUAL has a value other than the default. More importantly, the documentation I found states that WGL_GENERIC_ACCELERATION_ARB asks for an MDC driver, which, although I don't know much about this topic, doesn't seem like the correct choice here. As mentioned previously, the end effect is that requesting hardware acceleration in Windows XP actually forces the renderer into software mode (on my system at least), which I'm guessing isn't the desired behavior.
Mon, 07 Mar 2011 09:58:21 -0800 Enabled multi-touch
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 09:58:21 -0800] rev 5445
Enabled multi-touch
Mon, 07 Mar 2011 09:57:59 -0800 Added gesture test program
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Mar 2011 09:57:59 -0800] rev 5444
Added gesture test program
(0) -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 tip