Wed, 19 Jan 2011 23:47:50 -0800 Fixed bug #1028
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 23:47:50 -0800] rev 5052
Fixed bug #1028 pelya 2010-07-21 04:54:41 PDT GLES_UpdateTexture() ignores pitch value, because of that some textures created with SDL_CreateTextureFromSurface() are drawn incorrectly, especially if image width is not multiplier of 2.
Wed, 19 Jan 2011 23:45:29 -0800 Fixed bug #1027
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 23:45:29 -0800] rev 5051
Fixed bug #1027 Vittorio Giovara 2010-07-17 19:21:36 PDT fix the double free error in SDL_uikitview the variable 'textfield' is initialialized and set to autorelease. however in the dealloc method a second [release] is sent. If the textfield has not been set to nil before (with a viewDidUnload for example) this can lead to awful hard-to-find crashes when the SDL code terminates. the error message is -[textfield release] message sent to deallocated instance 0x4e5fa90 the fix is simple, just release the object as soon as it is added to the subview, see attached patch
Wed, 19 Jan 2011 22:55:51 -0800 SDL doesn't depend on GLU, and overwhelming feedback from the mailing list is that people don't want it included in SDL_opengl.h
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 22:55:51 -0800] rev 5050
SDL doesn't depend on GLU, and overwhelming feedback from the mailing list is that people don't want it included in SDL_opengl.h
Wed, 19 Jan 2011 22:39:02 -0800 John Wilson 2010-08-17 17:09:16 PDT
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 22:39:02 -0800] rev 5049
John Wilson 2010-08-17 17:09:16 PDT The are no event handlers for the middle mouse button, right mouse buttons, and mouse wheel in the latest HG revision 4636. It has been like this for 3 months. I made a patch for this, though I'm not sure if the Xbutton or mouse wheel code is "correct" by your standards.
Wed, 19 Jan 2011 22:25:40 -0800 PS3 Linux is no more...
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 22:25:40 -0800] rev 5048
PS3 Linux is no more...
Wed, 19 Jan 2011 22:21:31 -0800 Nobody has stepped up to maintain an svgalib driver. Bye bye! :)
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 22:21:31 -0800] rev 5047
Nobody has stepped up to maintain an svgalib driver. Bye bye! :)
Wed, 19 Jan 2011 22:20:44 -0800 Clearing the API changes for the 1.3.0 release
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 22:20:44 -0800] rev 5046
Clearing the API changes for the 1.3.0 release
Wed, 19 Jan 2011 22:18:45 -0800 Nobody has stepped up to maintain a framebuffer console driver. Bye bye! :)
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 22:18:45 -0800] rev 5045
Nobody has stepped up to maintain a framebuffer console driver. Bye bye! :)
Wed, 19 Jan 2011 19:51:04 -0800 Removed debug print statements
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 19:51:04 -0800] rev 5044
Removed debug print statements
Wed, 19 Jan 2011 16:06:47 -0800 Florian Forster to sdl
Sam Lantinga <slouken@libsdl.org> [Wed, 19 Jan 2011 16:06:47 -0800] rev 5043
Florian Forster to sdl in SDL 1.3 (revision 5508 from SVN), the method used to calculate the bits per pixel from a “int format” differ between “SDL_ListModes” (which always uses the “SDL_BITSPERPIXEL” macro) and “SDL_PixelFormatEnumTo- Masks” (which uses either “SDL_BITSPERPIXEL” or “SDL_BYTESPERPIXEL * 8”, depending on the value of “SDL_BYTESPERPIXEL”). Because the values are later compared in “SDL_ListModes” this may lead to some valid video modes not being returned. In my case the only mode returned by “SDL_GetNumDisplayModes” was dismissed and NULL was returned. (This led to the calling application sticking its head in the sand.) The attached patch copies the method used within “SDL_PixelFormatEnumTo- Masks” to “SDL_ListModes”. This solved the problem for me though I don't fully understand the method used by “SDL_PixelFormatEnumToMasks”.
(0) -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 tip