Tue, 22 Sep 2009 02:22:14 +0000 Whoops, this breaks building on Mac OS X 10.4 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Tue, 22 Sep 2009 02:22:14 +0000] rev 4229
Whoops, this breaks building on Mac OS X 10.4
Mon, 21 Sep 2009 12:04:11 +0000 Added header guards for SDLMain.h SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 12:04:11 +0000] rev 4228
Added header guards for SDLMain.h
Mon, 21 Sep 2009 11:48:03 +0000 Fix for expression error by Torsten Giebl - Thanks! :) SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 11:48:03 +0000] rev 4227
Fix for expression error by Torsten Giebl - Thanks! :)
Mon, 21 Sep 2009 11:34:50 +0000 Fixed bug #638 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 11:34:50 +0000] rev 4226
Fixed bug #638 Philipp Nordhus 2008-11-05 13:56:33 PST The Linux version of SDL_SYS_JoystickQuit() tries to free an invalid pointer when the number of joysticks was reduced since the last call. Reproduce: Connect two joysticks, call SDL_Init() and SDL_Quit(), then disconnect one joystick and call the functions again.
Mon, 21 Sep 2009 11:32:58 +0000 Fixed bug #637 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 11:32:58 +0000] rev 4225
Fixed bug #637 Switched right click emulation to be Ctrl-click, which matches Mac OS X
Mon, 21 Sep 2009 11:30:54 +0000 Whoops, need both the header and the library! SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 11:30:54 +0000] rev 4224
Whoops, need both the header and the library!
Mon, 21 Sep 2009 11:14:36 +0000 Fixed bug #727 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 11:14:36 +0000] rev 4223
Fixed bug #727 Lorenzo Desole 2009-04-19 07:36:10 PDT I am one of the developers of a multimedia application (My Media System MMS), which uses SDL. MMS is normally running in fullscreen mode but it switches it off before launching external applications (mplayer, xine, etc.). The problem with fullscreen is that when the latter is switched off either via SDL_WM_ToggleFullScreen() or SDL_SetVideoMode(), SDL compares the current screen sizes with the ones saved when the video system was initted, and if they don't match, it calls XF86VidModeSwitchToMode() to switch to the old modeline. This makes it impossible for external programs and for MMS itself to use RandR to change the screen size, because next time fullscreen mode is turned off, it bombs out with the following error: X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 136 (XFree86-VidModeExtension) Minor opcode of failed request: 10 (XF86VidModeSwitchToMode) [...] Obviously this happens only if the new screen resolution is smaller than the original one and XF86VidModeSwitchToMode() can't succeed. I couldn't find any way to inform SDL that the screen resolution it uses as reference is no longer valid. This can be fixed by adding "save_mode(this)" to ./src/video/x11/SDL_x11modes.c, API X11_EnterFullScreen(_THIS), like this: int X11_EnterFullScreen(_THIS) { int okay; + save_mode(this); I can't rule out possible side effects, but I don't see any. While I admit this is a minor issue for the general users, it is a major showstopper for our program where the ability to change screen resolution and refresh rate according to the movie being played, is very important. Thanks in advance.
Mon, 21 Sep 2009 11:04:32 +0000 Fixed bug #714 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 11:04:32 +0000] rev 4222
Fixed bug #714 fuzzyTew@gmail.com 2009-03-14 15:18:45 PDT Created an attachment (id=305) [details] patch to change HAVE_ICONV to HAVE_ICONV_H There are two separate iconv checks in configure -- one for the header file and one for the library. include/SDL_stdinc.h uses the library define to see whether or not it should reference the types defined in the header, which naturally breaks if the library exists and the header does not.
Mon, 21 Sep 2009 10:23:07 +0000 Fixed bug #674 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 10:23:07 +0000] rev 4221
Fixed bug #674 Matej 2009-01-08 09:25:34 PST Hello, I maintain a cross-platform project that uses SDL. One of the users who runs OSX has told me that he has problems with linking to SDL due to missing -framework option. I think that the problem is because of this: 'sdl-config --libs' outputs '-L/opt/local/lib -lSDLmain -lSDL -Wl,-framework,Cocoa' All the options are passed to the linker except the last one. I think that the good output should be just: '-L/opt/local/lib -lSDLmain -lSDL -framework Cocoa' since those options (--libs) are passed to the linker, so the '-Wl' option is redundant and possibly harmful in this very case I use autotools with libtool to do the build... Regards, Matej
Mon, 21 Sep 2009 09:58:43 +0000 Fixed bug #795 SDL-1.2
Sam Lantinga <slouken@libsdl.org> [Mon, 21 Sep 2009 09:58:43 +0000] rev 4220
Fixed bug #795 Andrey 2009-09-14 21:16:53 PDT WinCE GetCursorPos fixed I'm using iPAQ HP rx5919, with Windows Mobile 5. And I also use mingw32ce 0.59.1 toolchain. I fixed this, see attachment patch.
(0) -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 tip