Wed, 28 Sep 2005 06:38:22 +0000 Typo that broke Windows builds.
Ryan C. Gordon <icculus@icculus.org> [Wed, 28 Sep 2005 06:38:22 +0000] rev 1150
Typo that broke Windows builds.
Wed, 28 Sep 2005 03:34:24 +0000 Same inline asm bug in S8 mixer, fixed last night, is also in the MSVC version.
Ryan C. Gordon <icculus@icculus.org> [Wed, 28 Sep 2005 03:34:24 +0000] rev 1149
Same inline asm bug in S8 mixer, fixed last night, is also in the MSVC version.
Wed, 28 Sep 2005 02:26:29 +0000 Patched inline assembly to compile on gcc 4.0.1. Details are here:
Ryan C. Gordon <icculus@icculus.org> [Wed, 28 Sep 2005 02:26:29 +0000] rev 1148
Patched inline assembly to compile on gcc 4.0.1. Details are here: http://bugs.gentoo.org/show_bug.cgi?id=104437 I believe the patch is from Harald van Dijk (comment #16 at the above url).
Tue, 27 Sep 2005 12:14:17 +0000 From: "Alex Volkov" <avcp-sdlmail@usa.net>
Ryan C. Gordon <icculus@icculus.org> [Tue, 27 Sep 2005 12:14:17 +0000] rev 1147
From: "Alex Volkov" <avcp-sdlmail@usa.net> To: "'A list for developers using the SDL library. \(includesSDL-announce\)'" <sdl@libsdl.org> Date: Mon, 19 Sep 2005 18:59:43 -0400 Subject: [SDL] [patch] Volume multiplier bug in The volume multiplier in SDL_MixAudio_MMX_S8() is formed from the wrong register.
Tue, 27 Sep 2005 11:27:38 +0000 Date: Sat, 17 Sep 2005 13:38:49 +0200
Ryan C. Gordon <icculus@icculus.org> [Tue, 27 Sep 2005 11:27:38 +0000] rev 1146
Date: Sat, 17 Sep 2005 13:38:49 +0200 From: Jon Daniel <forcemaster@gmx.net> To: sdl@libsdl.org Subject: [SDL] SDL_SemWaitTimeout patch for BeOS The current SDL-1.2.9/src/thread/beos/SDL_syssem.c returns -1 if the acquire_sem timeouts which according to the DocWiki is not correct. I've added support for the B_TIMED_OUT and B_WOULD_BLOCK in the switch. Jon Daniel
Tue, 27 Sep 2005 09:00:42 +0000 Patch from Martin Lange (mala-sdl at hotmail.com) to unregister SDL's win32
Ryan C. Gordon <icculus@icculus.org> [Tue, 27 Sep 2005 09:00:42 +0000] rev 1145
Patch from Martin Lange (mala-sdl at hotmail.com) to unregister SDL's win32 windowclass when shutting down the video subsystem...this allows you to safely unload/reload the SDL shared library on Windows between initializations. Discussion is here: http://www.devolution.com/pipermail/sdl/2005-February/067424.html
Tue, 27 Sep 2005 08:36:28 +0000 Date: Sun, 11 Sep 2005 14:41:07 +0300 (EEST)
Ryan C. Gordon <icculus@icculus.org> [Tue, 27 Sep 2005 08:36:28 +0000] rev 1144
Date: Sun, 11 Sep 2005 14:41:07 +0300 (EEST) From: =?ISO-8859-1?Q?Martin_Storsj=F6?= <martin@martin.st> To: sdl@libsdl.org Subject: [SDL] [PATCH] Switching between fullscreen/windowed on OS X Hi, When switching from fullscreen to windowed mode for opengl applications, the current version of SDL sets an harmless error, regarding usage of a NULL semaphore. This is due to code which tries to shut down a blitting thread, which is only started for double buffered 2d video modes, not for opengl. The attached patch fixes this. // Martin
Thu, 22 Sep 2005 08:48:16 +0000 Replaced Mac OS X's C++ cdrom code with almost-direct translation to C. Sam
Ryan C. Gordon <icculus@icculus.org> [Thu, 22 Sep 2005 08:48:16 +0000] rev 1143
Replaced Mac OS X's C++ cdrom code with almost-direct translation to C. Sam requested this effort on the mailing list, apparently because of binary compatibility issues between 10.4 and earlier systems (or gcc4 and earlier compilers?). Works fine with SDL12/test/testcdrom.c, with this command line: ./testcdrom -status -list -play -sleep 5000 -pause -sleep 3000 -resume \ -sleep 5000 -stop -sleep 3000 -play -sleep 3000 -stop \ -sleep 3000 -eject Unix Makefiles work, XCode project still need updating for new filenames.
Sun, 11 Sep 2005 04:15:44 +0000 Date: Fri, 2 Sep 2005 21:56:50 -0400
Sam Lantinga <slouken@libsdl.org> [Sun, 11 Sep 2005 04:15:44 +0000] rev 1142
Date: Fri, 2 Sep 2005 21:56:50 -0400 From: Mike Frysinger Subject: [SDL] [patch] make sure autotools worked the current autogen.sh runs a bunch of autotools without actually checking the results ... find attached a patch to add some simple sanity checks
Thu, 08 Sep 2005 18:26:56 +0000 If couldn't load a needed GL symbol in SDL_SetVideoMode(), report it more
Ryan C. Gordon <icculus@icculus.org> [Thu, 08 Sep 2005 18:26:56 +0000] rev 1141
If couldn't load a needed GL symbol in SDL_SetVideoMode(), report it more specifically. Patch by Anders F Bj´┐Żrklund <afb@algonet.se>. --ryan.
(0) -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 tip