Sun, 07 May 2006 04:02:48 +0000 Fixed bug #217
Sam Lantinga <slouken@libsdl.org> [Sun, 07 May 2006 04:02:48 +0000] rev 1771
Fixed bug #217 Sort the DirectX video modes largest to smallest
Sun, 07 May 2006 03:44:58 +0000 Fixed bug #216
Sam Lantinga <slouken@libsdl.org> [Sun, 07 May 2006 03:44:58 +0000] rev 1770
Fixed bug #216 The attached files allow building the SDL library and tests with the Open Watcom compiler for Windows: - static library or DLL - Debug or Release builds available - uses register calling convention of Open Watcom - wmake target to build the SDL test samples Following is a table that shows what works and what doesn't, yet: checkkeys + graywin + loopwave + testalpha + testbitmap + testdyngl + testerror + testfile + testgamma + testgl + testhread + testiconv - (all failed) testkeys + testlock + (after removing calls to raise() from signal handler) testoverlay + (needs 'set SDL_VIDEODRIVER=directx') testoverlay2 + (-"-) testpalette + testplatform + testsem + testsprite + testtimer + testver + testvidinfo + testwin - (fading doesn't seem right) testwm + torturethread + testcdrom + testjoystick not tested threadwin + TODO: - make stack calling convention work (has linking issues with dxguid.lib) - perform testjoystick (I don't have a joystick) - investigate fading in testwin - merge with OS/2 port - add DOS target
Sun, 07 May 2006 03:40:06 +0000 Fixed bug #215
Sam Lantinga <slouken@libsdl.org> [Sun, 07 May 2006 03:40:06 +0000] rev 1769
Fixed bug #215 The current SVN trunk is missing the SDLCALL specifier at numerous locations. It has to be added for all (possibly user provided) callbacks. I stumbled over this while creating a makefile for the OpenWatcom compiler for Win32.
Fri, 05 May 2006 05:50:26 +0000 Fixed bug #80
Sam Lantinga <slouken@libsdl.org> [Fri, 05 May 2006 05:50:26 +0000] rev 1768
Fixed bug #80 Date: 21 Apr 2003 17:20:20 +0100 From: Alan Swanson <swanson@uklinux.net> Subject: [SDL] New XFree 4.3 Video Mode Patch If you look at the unsorted list of modes returned by X, here's mine; 1280 x 1024 @ 85.0 > 1024 x 768 @ 100.3 > USER 800 x 600 @ 125.5 > SET 640 x 480 @ 124.9 > 1280 x 1024 @ 75.0 ] 1280 x 1024 @ 60.0 ] 1280 x 960 @ 85.0 ] X11 1280 x 960 @ 60.0 ] AUTO 1152 x 864 @ 75.0 ]=20 1152 x 768 @ 54.8 ] 960 x 720 @ 120.0 ] ... 640 x 400 @ 85.1 ] 256k 576 x 432 @ 150.0 ] 249k PIXEL 640 x 350 @ 85.1 ] 224k COUNT 576 x 384 @ 109.6 ] 221k ... The user set modes come first followed by X set modes which are ordered by decreasing number of pixels and refresh. The reason why every other library or program not using SDL working is due to SDL scanning the modes in reverse getting X11 provided modes modes with the lowest refresh.
Fri, 05 May 2006 05:09:10 +0000 Fixed bug #196
Sam Lantinga <slouken@libsdl.org> [Fri, 05 May 2006 05:09:10 +0000] rev 1767
Fixed bug #196 Use the title and icon stored in the SDL video info, when creating X11 windows.
Thu, 04 May 2006 16:52:53 +0000 (none)
Sam Lantinga <slouken@libsdl.org> [Thu, 04 May 2006 16:52:53 +0000] rev 1766
(none)
Thu, 04 May 2006 16:51:07 +0000 Fixed bug #45
Sam Lantinga <slouken@libsdl.org> [Thu, 04 May 2006 16:51:07 +0000] rev 1765
Fixed bug #45 Improved Xinerama support. Added support for the SDL_VIDEO_FULLSCREEN_HEAD environment variable, currently supported on X11 Xinerama configurations. Only use the VidMode extension on the primary head.
Thu, 04 May 2006 13:47:19 +0000 The install target depends on the libraries being built
Sam Lantinga <slouken@libsdl.org> [Thu, 04 May 2006 13:47:19 +0000] rev 1764
The install target depends on the libraries being built
Thu, 04 May 2006 12:08:05 +0000 Updated to include new languages and platform support
Sam Lantinga <slouken@libsdl.org> [Thu, 04 May 2006 12:08:05 +0000] rev 1763
Updated to include new languages and platform support
Thu, 04 May 2006 11:59:55 +0000 Date: Thu, 4 May 2006 08:44:10 +0200 (CEST)
Sam Lantinga <slouken@libsdl.org> [Thu, 04 May 2006 11:59:55 +0000] rev 1762
Date: Thu, 4 May 2006 08:44:10 +0200 (CEST) From: Doodle Subject: Re: SDL OS/2 build updated? It seems that I made a mistake in the previous Watcom makefile, leaving out some .c files from linking, this is now fixed, and everything builds well now. Doodle
(0) -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 tip