A little more work on the Emscripten buildbot script.
authorRyan C. Gordon <icculus@icculus.org>
Wed, 24 Dec 2014 13:03:20 -0500
changeset 9284 f5fb020fb928
parent 9283 6723e3e133ea
child 9285 559ac7dd4ee4
A little more work on the Emscripten buildbot script. Should upload tarballs now, etc.
build-scripts/emscripten-buildbot.sh
--- a/build-scripts/emscripten-buildbot.sh	Wed Dec 24 12:49:35 2014 -0500
+++ b/build-scripts/emscripten-buildbot.sh	Wed Dec 24 13:03:20 2014 -0500
@@ -7,6 +7,11 @@
    exit 1
 fi
 
+TARBALL="$1"
+if [ -z $1 ]; then
+    TARBALL=sdl-emscripten.tar.xz
+fi
+
 cd `dirname "$0"`
 cd ..
 SDLBASE=`pwd`
@@ -39,21 +44,26 @@
 source "$ENVSCRIPT"
 
 echo "Setting up..."
-set -e
 set -x
 cd "$SDLBASE"
 rm -rf buildbot
+rm -rf emscripten-sdl2-installed
 mkdir buildbot
-cd buildbot
+pushd buildbot
 
 echo "Configuring..."
-emconfigure ../configure --host=asmjs-unknown-emscripten --disable-assembly --disable-threads --enable-cpuinfo=false CFLAGS="-O2 -Wno-warn-absolute-paths"
+emconfigure ../configure --host=asmjs-unknown-emscripten --disable-assembly --disable-threads --enable-cpuinfo=false CFLAGS="-O2 -Wno-warn-absolute-paths -Wdeclaration-after-statement -Werror=declaration-after-statement" --prefix="$SDLBASE/emscripten-sdl2-installed"
 
 echo "Building..."
 emmake $MAKE
 
-set +x
-echo "Done! The library is in $SDLBASE/buildbot/build/.libs/libSDL2.a ..."
+echo "Moving things around..."
+emmake $MAKE install
+mkdir -p ./usr
+mv "$SDLBASE/emscripten-sdl2-installed" ./usr/local
+popd
+tar -cJvvf $TARBALL -C buildbot usr
+rm -rf buildbot
 
 exit 0