Thu, 14 Aug 2014 21:33:24 -0400 Short circuit case-insensitive compare of two equal Unicode codepoints.
Ryan C. Gordon <icculus@icculus.org> [Thu, 14 Aug 2014 21:33:24 -0400] rev 1351
Short circuit case-insensitive compare of two equal Unicode codepoints.
Thu, 14 Aug 2014 21:17:04 -0400 PHYSFS_enumerateFiles() actually promises sorting order, and always has.
Ryan C. Gordon <icculus@icculus.org> [Thu, 14 Aug 2014 21:17:04 -0400] rev 1350
PHYSFS_enumerateFiles() actually promises sorting order, and always has.
Thu, 14 Aug 2014 21:27:00 -0400 Backport from default branch: corrected PHYSFS_enumerateFiles() documentation. stable-1.0
Ryan C. Gordon <icculus@icculus.org> [Thu, 14 Aug 2014 21:27:00 -0400] rev 1349
Backport from default branch: corrected PHYSFS_enumerateFiles() documentation. (transplanted from aaa1204a4426c5412d9c2814e41e0b7066db060c)
Thu, 14 Aug 2014 21:27:00 -0400 Backport from default branch: corrected PHYSFS_enumerateFiles() documentation. stable-2.0
Ryan C. Gordon <icculus@icculus.org> [Thu, 14 Aug 2014 21:27:00 -0400] rev 1348
Backport from default branch: corrected PHYSFS_enumerateFiles() documentation.
Sun, 20 Jul 2014 13:36:56 +0200 Fix NULL flush() in PHYSFS_Io crash
Willi Schinmeyer <willi@schinmeyer.de> [Sun, 20 Jul 2014 13:36:56 +0200] rev 1347
Fix NULL flush() in PHYSFS_Io crash
Fri, 07 Feb 2014 16:31:32 -0500 Static analysis fixes backported to the stable-2.0 branch. stable-2.0
Ryan C. Gordon <icculus@icculus.org> [Fri, 07 Feb 2014 16:31:32 -0500] rev 1346
Static analysis fixes backported to the stable-2.0 branch.
Fri, 07 Feb 2014 16:23:12 -0500 This returns -1 on error, not zero. :/
Ryan C. Gordon <icculus@icculus.org> [Fri, 07 Feb 2014 16:23:12 -0500] rev 1345
This returns -1 on error, not zero. :/
Fri, 07 Feb 2014 16:22:43 -0500 PHYSFS_stat() returns zero on error, not -1.
Ryan C. Gordon <icculus@icculus.org> [Fri, 07 Feb 2014 16:22:43 -0500] rev 1344
PHYSFS_stat() returns zero on error, not -1.
Fri, 07 Feb 2014 16:22:54 -0500 We always use miniz now.
Ryan C. Gordon <icculus@icculus.org> [Fri, 07 Feb 2014 16:22:54 -0500] rev 1343
We always use miniz now.
Fri, 07 Feb 2014 16:17:48 -0500 Renamed a function to make Clang static analysis happy.
Ryan C. Gordon <icculus@icculus.org> [Fri, 07 Feb 2014 16:17:48 -0500] rev 1342
Renamed a function to make Clang static analysis happy. "Object leaked: allocated object is returned from a function whose name ('cfallocDesc') does not contain 'Copy' or 'Create'. This violates the naming convention rules given in the Memory Management Guide for Core Foundation" (it doesn't actually leak, but okay, it's a reasonable naming convention.)
(0) -1000 -300 -100 -10 +10 +100 +300 tip