Hopefully fix broken autoconfs.
authorRyan C. Gordon <icculus@icculus.org>
Sat, 17 Aug 2002 13:54:54 +0000
changeset 459 5fa02060a63f
parent 458 4eb9811905c0
child 460 bcbf4788c477
Hopefully fix broken autoconfs.
configure.in
--- a/configure.in	Fri Aug 16 15:58:26 2002 +0000
+++ b/configure.in	Sat Aug 17 13:54:54 2002 +0000
@@ -70,15 +70,15 @@
               , enable_debug=yes)
 if test x$enable_debug = xyes; then
   if test x$ac_cv_prog_cc_g = xyes; then
-    CFLAGS="-g -O0"
+    PHYSFSCFLAGS="-g -O0"
   else
-    CFLAGS="-O0"
+    PHYSFSCFLAGS="-O0"
   fi
-  CFLAGS="$CFLAGS -Werror -Wall"
+  PHYSFSCFLAGS="$PHYSFSCFLAGS -Werror -Wall"
   AC_DEFINE([DEBUG], 1, [define if debug build is enabled])
   AC_DEFINE([DEBUG_CHATTER], 1, [define if debug chatter is enabled])
 else
-  CFLAGS="-O2"
+  PHYSFSCFLAGS="-O2"
   AC_DEFINE([NDEBUG], 1, [define if debug build is disabled])
 fi
 
@@ -325,7 +325,7 @@
 AC_MSG_CHECKING([if this is Cygwin])
 if test x$build_os = xcygwin; then
   this_is_cygwin=yes
-  CFLAGS="$CFLAGS -DWIN32"
+  PHYSFSCFLAGS="$PHYSFSCFLAGS -DWIN32"
   enable_pthreads=no
   have_non_posix_threads=yes
 else
@@ -351,7 +351,7 @@
   x=`echo $build_os |tr A-Z a-z |sed "s/.*freebsd.*/freebsd/"`
   if test x$x = xfreebsd; then
     this_is_freebsd=yes
-    LDFLAGS="$LDFLAGS -pthread"
+    PHYSFSLDFLAGS="$PHYSFSLDFLAGS -pthread"
   fi
 
   AC_MSG_RESULT([$this_is_freebsd])
@@ -363,7 +363,7 @@
   x=`echo $build_os |tr A-Z a-z |sed "s/.*openbsd.*/openbsd/"`
   if test x$x = xopenbsd; then
     this_is_openbsd=yes
-    LDFLAGS="$LDFLAGS -pthread"
+    PHYSFSLDFLAGS="$PHYSFSLDFLAGS -pthread"
   fi
 
   AC_MSG_RESULT([$this_is_openbsd])
@@ -388,7 +388,7 @@
   x=`echo $build_os |tr A-Z a-z |sed "s/.*os2.*/os2/"`
   if test x$x = xos2; then
     this_is_os2=yes
-    CFLAGS="$CFLAGS -DOS2"
+    PHYSFSCFLAGS="$PHYSFSCFLAGS -DOS2"
   fi
 
   AC_MSG_RESULT([$this_is_os2])
@@ -440,8 +440,8 @@
 
 AC_CHECK_SIZEOF(int, 4)
 
-CFLAGS="$CFLAGS -D_REENTRANT -D_THREAD_SAFE"
-LDFLAGS="$LDFLAGS -no-undefined"
+CFLAGS="$CFLAGS $PHYSFSCFLAGS -D_REENTRANT -D_THREAD_SAFE"
+LDFLAGS="$LDFLAGS $PHYSFSLDFLAGS -no-undefined"
 
 dnl Add Makefile conditionals
 AM_CONDITIONAL(BUILD_ZLIB, test x$enable_internal_zlib = xyes)